EU Production Issues

Incident Report for META-INF

Resolved

After monitoring the environment overnight and through the standard morning load period, we can now confirm that the issue has been resolved and services have returned to normal operation.

The EU production environment is stable, including the previously affected MS Graph connections.

We will continue with the remaining internal investigations, and a public post-mortem report will be made available once all relevant findings have been completed and reviewed.

We sincerely apologize for the disruption and thank you for your patience and understanding throughout this incident.
Posted Mar 13, 2026 - 10:29 CET

Monitoring

We have identified the issues, which were related to infrastructure.

The applied fixes appear to have resolved the currently known problems, including the MS Graph connection issues.

We are continuing to monitor the EU production environment closely and will keep monitoring it for a while to ensure stability.

Thank you for your patience, and we apologize again for the inconvenience.
Posted Mar 12, 2026 - 13:00 CET

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 12:57 CET

Update

Based on our investigation so far, the issue appears to affect only MS Graph API connections.

The impact is not consistent across all customers or mailboxes, and even the behavior of a single mailbox may vary over time. In practice, some fetch and send attempts fail intermittently and seemingly at random, while others continue to work normally.

This non-deterministic behavior makes the issue more difficult to diagnose and resolve. Our development and DevOps teams are continuing to investigate with the highest priority.

As a possible workaround, if critical business processes depend on email flow, and if your internal company policy allows it, we recommend temporarily switching to Microsoft IMAP/SMTP with OAuth connection mode, which continues to operate reliably at this time.

We will share further updates as soon as more information becomes available. We sincerely apologize for the continued disruption and appreciate your patience.
Posted Mar 12, 2026 - 11:58 CET

Update

When yesterday’s outage was resolved, the accumulated event queue and email backlog most likely placed excessive load on the system, causing it to fail again.

This also led to UI-related issues, which should now be resolved. If you experienced problems accessing the UI, please try opening the app menu again. At this time, the UI appears to be functional and app configurations should be available again.

There is also a separate known issue currently affecting MS Graph connections. Our team is actively working to restore these connections as well.

Unfortunately, the root cause of the incident remains unclear, as there were no updates or maintenance activities underway on our side at the time. We are therefore investigating other dependencies that may be contributing to the problem.

We will continue to share updates as soon as more information becomes available. We sincerely apologize for the ongoing disruption and appreciate your patience.
Posted Mar 11, 2026 - 16:20 CET

Investigating

We are currently experiencing issues affecting our EU production environment.

Our team is actively investigating the problem and working to restore full service as quickly as possible.

We will share another update as soon as we have more information.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 11, 2026 - 12:09 CET
This incident affected: Email This Issue (Email This Issue Cloud App).