Delay in email processing
Incident Report for META-INF
Resolved
The issue of slow email downloading has been resolved.
Posted Nov 11, 2022 - 08:56 CET
Monitoring
We are experiencing a delay in email downloading.
Posted Nov 10, 2022 - 11:21 CET
This incident affected: Email This Issue (Email This Issue Cloud App).