The performance metrics seem back to normal, thus the incident has been resolved.
Posted Mar 31, 2026 - 18:14 CEST
Monitoring
A memory-management issue had been identified, then respective resources in the production infrastructure were adjusted. We are actively monitoring the status of the service.
Posted Mar 31, 2026 - 16:01 CEST
Investigating
We are currently investigating an issue affecting incoming mail processing on our US production environment.
At this time, only incoming mail functionality is impacted, and the behavior is intermittent. The issue is not persistent and does not affect all customers. Other services remain fully operational.
Our team is actively working to identify the root cause and mitigate the issue.
We will provide further updates as soon as more information becomes available.
Posted Mar 31, 2026 - 14:48 CEST
This incident affected: Email This Issue (Email This Issue Cloud App).