All operations are now back to normal, and the backlog of outgoing emails has been fully processed. Our engineering team has identified and isolated the specific problematic messages that caused the initial service disruption.
To prevent similar occurrences, we will be implementing additional safeguards and structural improvements to our sending service down the line. We sincerely apologize for the inconvenience and disturbance this caused your workflow, and we thank you for your patience and understanding while we worked to resolve this issue.
Posted Sep 04, 2026 - 12:05 CEST
Monitoring
We have restarted the affected services and doubling the working threads to handle the accumulated queue. Outgoing emails are now successfully processing at a rate of over 200+ per minute. We expect the current backlog to be completely cleared within the next hour.
We will continue to monitor the system's performance closely until all delayed messages have been sent and full stability is confirmed.
Posted Sep 04, 2026 - 10:34 CEST
Investigating
We are currently experiencing an issue affecting outgoing services in our US Production environment. Our engineering team is aware of the situation and is actively investigating the root cause to restore full functionality. We will provide another update as soon as more information becomes available.
Posted Sep 04, 2026 - 10:03 CEST
This incident affected: Email This Issue (Email This Issue Cloud App).